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Dell Thunderbolt Docks Report Reduced Connectivity Error Message on Boot

Summary: The following article provides information about an error message seen on startup. This happens when connecting a Dell Thunderbolt docking station to a USB type-C port that does not support Thunderbolt 3 protocols. (Such as the WD19TB, WD19TBS, or WD22TB4 dock.) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A message appears during POST if a Dell Thunderbolt docking station is connected to a non-Thunderbolt USB Type-C port (See Figure.1) on any commercial Dell laptop. (WD19TB, WD19TBS, or WD22TB4.) Pressing the F1 key allows the laptop to boot normally. (See figure.2)

Note: The Dell Thunderbolt Docking Station (WD19TB, WD19TBS, or WD22TB4) functions on devices with a USB Type-C port that supports DisplayPort over USB-C or Thunderbolt. When connected to a DisplayPort over USB Type-C port, the Thunderbolt dock functions as a WD19 or WD19S dock. Verify that your computer supports DisplayPort over USB Type-C, Thunderbolt 3, or Thunderbolt 4.

Non-Thunderbolt Type-C port

(Figure.1 Non-Thunderbolt USB Type-C port)

Error Message before and after August 2019

(Figure.2 Error Message The Docking Station you have connected cannot provide full functionality while connected to the current port. If you have a Thunderbolt port, attach the docking station to that port for full functionality.)

The error message informs you that you should not expect Thunderbolt 3 connectivity from the dock. This is because it is not attached to a Thunderbolt port on the computer which it is attached to.

Thunderbolt Platforms

Latitude Precision XPS
5280 3520 9365
5480 5520 9360
5580 7520 9560
7280 7720 9575
7380 3530 9570
7480 7530 9360
7285 7530 9370
5289 2-in-1 7730 9000 2-in-1
7389 2-in-1 5530 2-in-1 9380
7290 5530 7390
7390 7540 7300
7490 7740 9300
7390 2-in-1 5540 9310
5491 7550 9315
5591 7750 9315 2-in-1
5290 2-in-1 5550 9320
5300 7560  
5400 7760  
5500 5560  
7300 7670  
7400 7770  
7400 2-in-1 5570  
5401    
5501    
5310    
5410    
5510    
5411    
5511    
7310    
7410    
5320    
5420    
5520    
5421    
5521    
7320    
7320 Detachable    
7420    
5330    
5430    
5530    
7330    
7330 rugged    
7430    
5431    
5531    

Non-Thunderbolt Platforms

Latitude Precision XPS
5280 3520 9575
5480 3530  
5580 5530 2-in-1  
7280    
7380    
7480    
5285 2-in-1    
5290    
5490    
5590    
7290    
7390    
7490    
7390 2-in-1    
5491    
5591    
3490    
3590    
5290 2-in-1    
5300    
5400    
5500    
3410    
3510    
3420    
3520    

Cause

A BIOS update resolves this.

Resolution

Updating the latest BIOS version on the computer helps to resolve the issue. To download and install the latest BIOS:

Warning: Dell Technologies recommends disconnecting any external devices like external hard disk drives, printers, scanners before updating the BIOS.
 
Warning: Dell laptops must have the battery installed and charged to at least 10% before you begin the BIOS update. Dell Technologies recommends connecting the laptop to AC power before proceeding with the update process.
 
Note: To learn more about updating the BIOS on a Dell computer, see the Dell Knowledge Base article: Dell BIOS Updates
  1. Browse to the Dell Drivers & Downloads Product Support Drivers Page

  2. Ensure that your computer model type is correct

  3. Select the Operating System

  4. Under Category, select BIOS

  5. Locate the latest System BIOS

  6. Click Download and save the file to your computer

  7. Open File Explorer and browse to the location where the downloaded file is saved

  8. Double-click the BIOS setup file and follow the on-screen instructions to complete the installation process

You can skip this message by pressing the F7 key or by disabling USB-C Dock warning messages in the BIOS. However, a second message is showing in Dell SupportAssist. It can only be adjusted with the setting continue on Warnings and Errors, but the error is shown on the next boot. (See figure.3)

Disabling the Thunderbolt boot message in the BIOS

(Figure.3 Disabling the Thunderbolt boot message in the BIOS.)

Additional Information

Affected Products

G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Mobile Workstations, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS, Dell Thunderbolt Dock – WD22TB4
Article Properties
Article Number: 000135678
Article Type: Solution
Last Modified: 21 Nov 2023
Version:  9
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