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TPM Option Is Missing in the System BIOS Setup Latitude, Precision, or XPS

Summary: The Trusted Platform Module (TPM) option may be missing in the system BIOS or Windows Operating System on your Dell Latitude, Dell Precision, or XPS system. Follow the steps outlined in this article to resolve this issue. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

You may encounter a situation where the Trusted Platform Module (TPM) 2.0 option is missing from the BIOS setup screen, the Security option, or that there is no TPM present when running the Trusted Platform Module Microsoft management console (TPM.msc) in Windows.

This issue may become apparent as the result of a BitLocker recovery message.

NOTE: This only applies to platforms that support or can be switched to TPM 2.0. (Skylake and Newer systems.)

Computers with encrypted hard drives installed may also experience a no-boot situation if the TPM option is missing. Check the BIOS settings to ensure that TPM is not missing. Also, follow the steps below to resolve the missing TPM issue if a no-boot occurs on an encrypted hard drive.

Cause

No cause information

Resolution

NOTE: Dell Technologies recommends that the entire installation base of applicable systems are updated, not just systems that are presenting issues with TPM.

If you are using UEFI boot mode, it is recommended to download and install the latest TPM 2.0 firmware version from Dell Support on applicable systems. The firmware is located under the Security category in the list of drivers. This new TPM 2.0 firmware should prevent this issue from occurring in the future.

If using Legacy boot mode, download and install the latest TPM 1.2 firmware version from the Dell Drivers & Downloads website on your applicable systems. The firmware is located under the Security category in the list of drivers.

NOTE: Search for drivers on the Dell Support Website by system model, not the service tag, as depending on the service tag entitlement, the TPM firmware files may not be displayed.

If TPM is not present, try the following troubleshooting steps:

  1. Update the system BIOS to the latest version available on the Dell Drivers & Downloads website.
  2. Power off the computer, then disconnect the AC power cable and leave the computer unplugged for about 30 seconds.
  3. Reconnect AC power to the computer and boot to the BIOS setup using the F12 one-time boot menu.
    NOTE: To ensure that TPM is turned on, you must press F2 to enter System Setup. Then go to the Security section and check that TPM is set to On under the TPM security settings.
  4. If TPM is restored, proceed with normal system operation.
  5. If TPM is still missing from the BIOS setup, contact Dell Technical Support for further assistance.

Additional Information

Affected Products

Latitude, XPS, Mobile Workstations
Article Properties
Article Number: 000132757
Article Type: Solution
Last Modified: 17 Sept 2024
Version:  14
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