Symptoms
Produits concernés :
- SupportAssist pour ordinateurs personnels
Versions concernées :
Lorsque vous ouvrez SupportAssist pour ordinateurs personnels v4.0 sur les ordinateurs sur lesquels le runtime WebView2 n’est pas installé, Edge affiche les messages suivants :
- Une version appropriée de Microsoft Edge Webview2 Runtime n’a pas été détectée. Téléchargez et installez WebView2 Runtime.
- Une erreur s’est produite lors de l’initialisation de webview2 : Object reference not set to an instance of an object.
Figure 1 : (En anglais uniquement) Messages affichés lors de la tentative d’ouverture de SupportAssist sans le runtime WebView2 installé
Cause
Le runtime Microsoft Edge WebView2 n’est pas installé ou corrompu.
Resolution
- Ouvrez le panneau de configuration et vérifiez que le runtime Microsoft Edge webview2 est installé.
Figure 2 : (En anglais uniquement) Microsoft Edge WebView2 Runtime répertorié sous Programmes et fonctionnalités
- S’il n’est pas installé, passez à l’étape 5.
- S’il est installé, double-cliquez sur Microsoft Edge Webview2 Runtime et sélectionnez l’option de réparation et laissez la fin se terminer.
- Ouvrez maintenant l’interface utilisateur SupportAssist à partir du menu Démarrer. L’interface utilisateur doit s’ouvrir correctement, ou passez à l’étape suivante.
- Téléchargez et installez la dernière version de Microsoft Edge Webview2 Runtime.
- Après avoir ouvert l’URL ci-dessus, vous trouverez plusieurs builds ou versions disponibles.
- Triez la dernière version disponible à l’aide de Dernière mise à jour.
Figure 3 : (En anglais uniquement) Trier par Dernière mise à jour
- Pour identifier votre Type de système, accédez à la barre de recherche et saisissez Informations système.
- Référez-vous au type de système pour la version de bit et utilisez la build appropriée dans la liste.
Figure 4 : (En anglais uniquement) Type de système de référence pour la version du bit
Affected Products
SupportAssist for Home PCs