Dell EMC Unity: Using Continuous Availability when upgrading to version 5.1.2 may cause SP panics (User Correctable)
Summary: When Continuous Availability (CA) is enabled on an SMB share, upgrading to version 5.1.2 may induce SP panics and SPs going in to service mode.
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Symptoms
Following the upgrade, SPs may panic and reboot into service mode. Users are unable to remove the SPs from service mode.
Cause
The issue is related to the Continuous Availability feature of SMB. It was found that in a few cases, customers who have Continuous Availability that is selected on their SMB shares, and who had high numbers of open file handles on those shares (greater than 97 open handles) led to a new variable (phMaxTimeout) having an unexpectedly high value. This induces the panic and service mode.
Resolution
Fix:
Upgrade to Dell EMC Unity Operating Environment (OE) version 5.1.3 to fix this issue.Workaround:
If you have already upgraded and have encountered this issue, contact Dell EMC Technical Support or your Authorized Service Provider and quote this Knowledgebase article ID.If you have not upgraded to version 5.1.2, and you cannot upgrade to 5.1.3, you must disable Continuous Availability on all your SMB shares before upgrading.
- In Unisphere, select the STORAGE heading and click File. Choose the SMB Shares tab.
- Click each SMB share and select Properties (click the pencil icon after selecting the share).
- In the Properties dialog, click the Advanced tab.
- Ensure that Continuous Availability is off.
-
uemcli -no /stor/prov/fs/cifs show -filter "Name","Availability enabled" -output csv uemcli -no /stor/prov/fs/cifs -id <share id> set -enableContinuousAvailability no
-
svc_nas ALL -param -f cifs -m smb2.defaultFdhv2Timeout -v 0
NOTE: Leave these settings in place until you can upgrade to 5.1.3. At that time, Continuous Availability may be reactivated.
Affected Products
Dell EMC UnityArticle Properties
Article Number: 000195010
Article Type: Solution
Last Modified: 28 Oct 2022
Version: 7
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