Symptoms
Il supporto YGeneric Canonical Ubuntu (alcuni supporti OEM Dell) o un altro supporto Linux non si avvia nell'ambiente live o nel programma di installazione come di consueto e il computer potrebbe invece smettere di rispondere o bloccarsi.
La prima fase di risoluzione dei problemi che potrebbe risolvere il problema di avvio e consentire di installare Ubuntu consiste nel disabilitare le funzionalità della scheda grafica Intel impostando l'opzione nomodeset prima dell'avvio.
È possibile eseguire questa operazione per l'avvio una tantum, come mostrato nella Soluzione 1, oppure è possibile renderlo permanente, come mostrato nella Soluzione 2.
Cause
Nota: La soluzione 1 è valida per l'avvio da USB o per installare un supporto. La soluzione 2 è utile per rendere permanente se il sistema operativo si arresta in modo anomalo o smette di rispondere dopo l'installazione.
Resolution
Soluzione 1
- Dopo aver collegato i supporti, accendere il computer.
- Osservare la schermata del bootloader GNU GRUB .
- Quando viene visualizzata l'opzione per Ubuntu mostrata, premere il tasto E sulla tastiera.
- Nell'editor, utilizzare i tasti freccia per individuare la fine della riga che inizia con quanto segue. Ogni bootloader può dire qualcosa di leggermente diverso.
linux /boot/vmlinuz***
- Digitare l'opzione di riga seguente alla fine della riga.
nomodeset
- Premere i tasti CTRL+X per avviare il normale programma di installazione o l'ambiente live come di consueto.
Soluzione 2
- Aprire un terminale e digitare quanto segue:
sudo gedit /etc/default/grub
- Immettere la password, se richiesto.
- Spostare il cursore sulla riga riportata di seguito:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- Modificare tale riga in modo che corrisponda a quanto segue:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
(è anche possibile rimuovere le variabili "quiet" e/o "splash" per risolvere i problemi di mancato avvio)
- Cliccare su Save.
- Chiudere la finestra.
- Nel terminale, digita quanto segue e premi invio:
sudo update-grub2
- Al termine dell'operazione, riavviare il computer con la modifica effettuata.
Fuori garanzia? Nessun problema: Accedere al sito web Dell.com/support, inserire il codice di matricola Dell e visualizzare le offerte disponibili.
NOTA: le offerte sono disponibili solo per i clienti di personal computer in Stati Uniti, Canada, Regno Unito, Francia, Germania e Cina. Server e storage non applicabili.