Zu den Hauptinhalten
  • Bestellungen schnell und einfach aufgeben
  • Bestellungen anzeigen und den Versandstatus verfolgen
  • Profitieren Sie von exklusiven Prämien und Rabatten für Mitglieder
  • Erstellen Sie eine Liste Ihrer Produkte, auf die Sie jederzeit zugreifen können.

Řešení problému se spouštěním po spuštění obnovení systému Ubuntu v operačním systému

Zusammenfassung: Tento článek slouží jako průvodce při obnovení z problému se spouštěním v počítači Dell se systémem Ubuntu Linux.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Následující článek obsahuje informace o problému se spuštěním operačního systému po spuštění nástroje pro obnovení operačního systému Ubuntu v noteboocích Dell.


Nedaří se vám spustit notebook se systémem Ubuntu po spuštění nástroje pro obnovení?

Aby bylo možné přejít k obnovení systému, primární pevný disk by měl být přiřazen jako /dev/sda.

V některých případech však čtečka karet Realtek RTS5170 omylem nahlásí čtečku karet jako /dev/sda ještě před skutečným pevným diskem.

Když k tomu dojde, primární pevný disk bude přiřazen jako /dev/sdb.

To znamená, že při příštím restartování systému po dokončení obnovení bude správce spouštění hledat primární pevný disk v nesprávném umístění, protože primární pevný disk bude označen jako /dev/sda. Položka správce spouštění se změní, takže se systém nespustí a zastaví se na níže uvedené obrazovce:

Gave up waiting for root device. Common problem:
 - Boot args (cat /proc/cmdline)
 - Check rootdelay: (did the system wait long enough?)
 - Check root: (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: ls /dev)
ALERT! /dev/disk/by-uuid/e279d132-d5b4-42a6-932f-225b4be3f0c8 does not exist. Dropping to a shell!

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in-commands.

(initramfs) _

Ursache

Nejsou k dispozici žádné informace o příčině.

Lösung

  1. Stáhněte si nejnovější bitovou kopii Ubuntu LTS z webu Ubuntu.com. Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.

  2. Vytvořte spustitelné paměťové zařízení USB nebo disk DVD s bitovou kopií systému Dell Ubuntu.

    • Vypálení spustitelného disku DVD se systémem Ubuntu ve funkčním počítači se systémem Windows (Windows 7 / 8):

      1. Pravým tlačítkem klikněte na staženou bitovou kopii ISO a vyberte možnost Otevřít v programu > Nástroj Windows pro vypalování bitových kopií.

      2. Vyberte umístění jednotky DVD-RW a zvolte možnost Vypálit. (Doporučujeme zaškrtnout možnost Po vypálení ověřit disk – tím se ověří, zda byla bitová kopie vypálena správně.)

    • Vypálení spustitelného paměťového zařízení USB ve funkčním počítači se systémem Windows (Windows 7 / 8):

      1. Stáhněte si instalační program USB, jako je například Pen Drive Linux USB Installer. Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.

      2. U tohoto konkrétního instalačního programu vyberte v rozevíracím seznamu možnost Ubuntu.

      3. Klikněte na možnost Browse (Procházet) a otevřete stáhnutou bitovou kopii ISO.

      4. Zvolte jednotku USB a klikněte na možnost Create (Vytvořit).

  3. Spusťte systém z paměťového zařízení USB nebo z vytvořeného disku DVD. Při zapnutí počítače může být nutné na obrazovce s logem společnosti Dell několikrát rychle stisknout klávesu F12. Zobrazí se nabídka výběru spouštěcího zařízení. (Vyberte možnost, která odpovídá používanému médiu.)

  4. V nabídce spuštění média vyberte možnost Try Ubuntu without installing.

  5. Tím se spustí počítač, ale na pevný disk se nic nenainstaluje. Na ploše stiskněte současně klávesy Ctrl+Alt+T a otevřete okno terminálu. Problém s umístěním spuštění vyřešíte následujícím postupem:

    1. Proveďte změnu na uživatele root.

      sudo –s

    2. Znovu připojte disk CD-ROM a nastavte jej pro čtení a zápis.

      mount –n –o remount, rw /cdrom/

    3. Zadejte příkaz.

      cd /cdrom/factory

    4. Upravte soubor /cdrom/factory/common.cfg pomocí editorů vi nebo gedit. Změňte původní příkaz na options="boot=casper automatic-ubiquity noprompt quiet splash -- modprobe.blacklist=rts5139 nomodeset".

    5. Uložte soubor, ukončete editor a okno terminálu a restartujte systém.

  6. Pokud se systém stále nepodaří spustit, zkuste následující postup:

    1. Spusťte diagnostiku a ujistěte se, že hardware funguje správně.

      1. Pokud kontrola selže, obraťte se na technickou podporu a předejte jí chybové hlášení a ověřovací kód.

      2. Pokud ne, pokračujte dalším krokem.

    2. V terminálu spusťte následující příkaz:

      ls -lah

    3. Pokud se zobrazí něco jiného než drwxrwxrwt, spusťte následující příkaz:

      chown username: username .Xauthority

    4. Pokud to nefunguje, spusťte:

      sudo chmod a+wt /tmp

    5. Můžete také zkusit spustit:

      dpkg-reconfigure lightdm

    6. Pokud žádná z těchto možností nefunguje, pak je nutné provést obnovení systému z bitové kopie nebo ze záložního média.


Další informace:

Poznámka: Podporu softwaru poskytuje společnost Canonical, a to následujícími způsoby:
Technická podpora poskytovaná společností Dell:
Poznámka: Vlastníte notebook Dell? Pokud se notebook nedaří zapnout, odešlete jej k záruční opravě. My problém rozpoznáme a vyřešíme. Tato služba je aktuálně dostupná v Kanadě, Francii, Německu, Itálii, Nizozemsku, Polsku, Velké Británii a Spojených státech amerických.

Betroffene Produkte

Inspiron
Artikeleigenschaften
Artikelnummer: 000129823
Artikeltyp: Solution
Zuletzt geändert: 31 Mai 2024
Version:  6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.