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Dell EMC VxRail: Node-Validierung zum Hinzufügen ist nach manuell konfigurierter Witness Traffic Separation (WTS) fehlgeschlagen

Zusammenfassung: Die Node-Erweiterung ist fehlgeschlagen, wenn der Witness-Datenverkehrs-VMkernel-Adapter auf ESXi-Hosts manuell konfiguriert wurde.

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Artikelinhalt


Symptome

Bei der Node-Erweiterung für VxRail Stretched Cluster oder VCF on VxRail Stretched Cluster ist die Validierung fehlgeschlagen:


In marvin.log gibt es NullPointerException für vlan-Validierung auf vss:

Ursache

Der Witness-Datenverkehrs-VMkernel-Adapter auf ESXi-Hosts wurde manuell konfiguriert. 

Um beispielsweise VCF auf einem verteilten VxRail-Cluster bereitzustellen, befolgte der Nutzer https://docs.vmware.com/en/VMware-Cloud-Foundation/4.1/com.vmware.vcf.vxrail.admin.doc/GUID-2E6741E8-F031-4BE4-B459-98E67B7FF4DF.html, um witness Traffic Separation für VMware Cloud Foundation auf Dell EMC VxRail zu konfigurieren, und konfigurierte den Witness-VMkernel-Adapter für vorhandene ESXi-Hosts mithilfe des Befehls:

esxcli vsan network ip add -i  -T=witness

Dies ist im Verfahren zum Hinzufügen von Nodes in VxRail 7.0.010 unerwartet.

Lösung

Damit neue Nodes zum Cluster hinzugefügt werden, setzen Sie die Konfiguration auf die Standardeinstellung zurück:

1. Melden Sie sich bei der ESXi-Benutzeroberfläche eines oder mehrerer neuer Nodes
an 2. Überprüfen Sie Portgruppen und VMkernel-NICs. Möglicherweise sind bereits Portgruppen und VMK wie unten konfiguriert:


3. Entfernen Sie vmks mit den Namen MANAGEMENT, VSAN und VMOTION.
4. Entfernen Sie Portgruppen mit dem Namen MANAGEMENT, VSAN, VMOTION und WITNESS.
5. Wenn der neue Node Layer-3-Node ist, setzen Sie die VLAN-ID) und die VMK-NIC-IPv4-Adresse der Verwaltungsnetzwerkportgruppe und anderer Porgroups zurück.
6. Die folgenden Abbildungen sind ein Beispiel für einen neuen Node nach dem Zurücksetzen.

 

Hinweis: Für alle vorhandenen Nodes ist ein Eingreifen von Dell Technologies Supportmitarbeitern erforderlich. Ein Skript ist erforderlich, um auf VxRail Manager ausgeführt zu werden. Wenden Sie sich an das Dell Technologies Supportcenter oder Ihren Servicemitarbeiter, um technischen Support zu erhalten, und geben Sie diese Lösungs-ID an.

Artikeleigenschaften


Betroffenes Produkt

VxRail Appliance Family, VxRail Software

Letztes Veröffentlichungsdatum

14 Dez. 2022

Version

5

Artikeltyp

Solution