Zu den Hauptinhalten
  • Bestellungen schnell und einfach aufgeben
  • Bestellungen anzeigen und den Versandstatus verfolgen
  • Erstellen Sie eine Liste Ihrer Produkte, auf die Sie jederzeit zugreifen können.
  • Verwalten Sie mit der Unternehmensverwaltung Ihre Dell EMC Seiten, Produkte und produktspezifischen Kontakte.

Как устранить проблему с загрузкой после запуска восстановления Ubuntu в операционной системе

Zusammenfassung: В этой статье рассматривается восстановление после ошибки «Нет загрузки» на ноутбуке Dell с помощью операционной системы Ubuntu.

Dieser Artikel wurde möglicherweise automatisch übersetzt. Wenn Sie eine Rückmeldung bezüglich dessen Qualität geben möchten, teilen Sie uns diese über das Formular unten auf dieser Seite mit.

Artikelinhalt


Symptome

В следующей статье представлена информация о проблеме с загрузкой операционной системы после запуска средства восстановления операционной системы Ubuntu на ноутбуках Dell.


Ноутбук с ОС Ubuntu не загружается после запуска средства восстановления?

На этапе восстановления основной жесткий диск обычно назначается как /dev/sda для продолжения восстановления системы.

Однако в некоторых случаях устройство считывания карт памяти Realtek RTS5170 будет сообщать о том, что /dev/sda — это устройство считывания карт памяти, помещая его впереди настоящего жесткого диска.

В этом случае основной жесткий диск будет называться /dev/sdb.

Это означает, что при следующей перезагрузке компьютера после восстановления менеджер загрузки будет искать основной жесткий диск в несоответствующем месте, так как он будет перемещен в /dev/sda. Изменение записи диспетчера загрузки приведет к тому, что система не загрузится и остановится, отображая на экране сообщение, как показано ниже :

Gave up waiting for root device. Common problem:
 - Boot args (cat /proc/cmdline)
 - Check rootdelay: (did the system wait long enough?)
 - Check root: (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: ls /dev)
ALERT! /dev/disk/by-uuid/e279d132-d5b4-42a6-932f-225b4be3f0c8 does not exist. Dropping to a shell!

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in-commands.

(initramfs) _

Ursache

Информация о причине недоступна.

Lösung

  1. Скачайте последнюю версию образа Ubuntu LTS с веб-сайта Ubuntu.com. Эта гиперссылка позволяет перейти на сайт за пределами Dell Technologies.

  2. Создайте загрузочный USB-накопитель или DVD-диск с образом Dell Ubuntu.

    • Запись загрузочного DVD-диска с операционной системой Ubuntu на рабочем ПК под управлением Windows (Windows 7 / 8):

      1. Нажмите правой кнопкой мыши на скачанный образ ISO и выберите Открыть с помощью > Средство записи образов дисков Windows.

      2. Выберите месторасположение дисковода DVD-RW и нажмите Запись. (Рекомендуется установить параметр Проверить диск после записи, который подтвердит правильность записи образа.)

    • Запись загрузочного USB-накопителя с операционной системой Ubuntu на рабочем ПК под управлением Windows (Windows 7 / 8):

      1. Скачайте установщик USB, например Pen Drive Linux USB Installer. Эта гиперссылка позволяет перейти на сайт за пределами Dell Technologies.

      2. В этом установщике выберите пункт Ubuntu из выпадающего меню.

      3. Нажмите Обзор и откройте загруженный образ ISO.

      4. Выберите USB-накопитель и нажмите Создать.

  3. Загрузите компьютер с созданного USB-накопителя или DVD-диска. При включении системы может потребоваться быстро нажать клавишу F12 на экране с логотипом Dell, чтобы вывести на экран меню выбора загрузочного устройства. (Выберите параметр, соответствующий используемому носителю.)

  4. Выберите пункт Try Ubuntu without installing в меню загрузки носителя.

  5. Это позволит загрузить рабочий стол, не устанавливая ничего на жесткий диск. Находясь на рабочем столе, нажмите сочетание клавиш Ctrl+Alt+T, чтобы открыть окно терминала. Для устранения проблемы с загрузкой выполните следующие действия:

    1. Получите права доступа root-пользователя.

      sudo –s

    2. Заново подключите CDROM, чтобы установить его в режим чтения-записи.

      mount –n –o remount, rw /cdrom/

    3. Введите команду.

      cd /cdrom/factory

    4. Отредактируйте файл /cdrom/factory/common.cfg с помощью редактора vi или gedit. Измените исходную команду, чтобы установить options="boot=casper automatic-ubiquity noprompt quiet splash -- modprobe.blacklist=rts5139 nomodeset"

    5. Сохраните файл, выйдите из редактора и окна терминала и перезагрузите компьютер.

  6. Если он по-прежнему не загружается, выполните следующие действия:

    1. Убедитесь, что оборудование работает нормально, запустив диагностику.

      1. При сбое диагностики обратитесь в службу технической поддержки и передайте сообщение об ошибке и код подтверждения.

      2. Если диагностика пройдена успешно, перейдите к следующему шагу.

    2. Введите в терминале следующую команду:

      ls -lah

    3. Если вы получили что-либо, кроме drwxrwxrwt, выполните следующую команду:

      chown username: username .Xauthority

    4. Если это не работает, выполните следующую команду:

      sudo chmod a+wt /tmp

    5. Также можно попробовать выполнить следующую команду:

      dpkg-reconfigure lightdm

    6. Если ни одно из действий не помогает, необходимо выполнить восстановление с образа системы или носителя для резервного копирования.


Дополнительная информация:

Примечание. Поддержка программного обеспечения осуществляется компанией Canonical следующими способами:
Техническая поддержка осуществляется компанией Dell:
Примечание. У вас есть ноутбук Dell? Отправьте свой ноутбук для гарантийного ремонта, и мы выявим и устраним проблемы с загрузкой, если они возникли на ноутбуке. В настоящее время эта услуга доступна в Канаде, Франции, Германии, Италии, Нидерландах, Польше, Великобритании и США.

Artikeleigenschaften


Betroffenes Produkt

Inspiron

Letztes Veröffentlichungsdatum

31 Mai 2024

Version

6

Artikeltyp

Solution