Zu den Hauptinhalten
  • Bestellungen schnell und einfach aufgeben
  • Bestellungen anzeigen und den Versandstatus verfolgen
  • Erstellen Sie eine Liste Ihrer Produkte, auf die Sie jederzeit zugreifen können.

Så här återställer du iDRAC (Integrated Dell Remote Access Controller)

Zusammenfassung: I den här artikeln beskrivs flera metoder för att återställa iDRAC (Integrated Dell Remote Access Controller) både lokalt och på distans, inklusive återställning, återställning till standardvärden och återställning till kundkonfiguration. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Integrated Dell Remote Access Controller (iDRAC) ansvarar för systemprofilinställningar och out-of-band-hantering. Ibland kan iDRAC sluta svara på grund av olika orsaker. Symptom på att iDRAC inte svarar omfattar följande:

  • RACADM-kommandon returnerar "ERROR: Unable to perform requested operation"
  • Ingen SSH-/Telnet-åtkomst till iDRAC (tidsgränsen för anslutningen nås)
  • Ingen webbläsaråtkomst till iDRAC
  • Pingning av iDRAC:s IP-adress misslyckas

Ursache

Det kan finnas olika orsaker till att iDRAC inte svarar. Dell Technologies rekommenderar att du ser till att systemet är uppdaterat till den senaste versionen av den fasta iDRAC-programvaran som är tillgänglig. Detta säkerställer bästa prestanda och de senaste säkerhetsuppdateringarna och korrigeringarna. iDRAC-uppdateringar kräver ingen omstart av värden, vilket möjliggör uppdateringar på plats. Versionen för fast programvara för iDRAC kan variera mellan olika servermodeller med iDRAC. Så här laddar du ner den senaste fasta iDRAC-programvaran för ditt system:

  1. Gå till Dells supportwebbplats och välj servermodell eller ange service tag-numret.
  2. Välj fliken Drivrutiner och hämtningsbara filer.
  3. Välj iDRAC med kategorin Lifecycle Controller .
  4. Du kan även välja operativsystem för ditt system.
  5. Ladda ner den senaste versionen för iDRAC med den fasta lifecycle controller-programvaran .
Uppdatering av fast programvara och drivrutiner på Dell PowerEdge-servrar innehåller en lista över flera metoder för att uppdatera iDRAC:s fasta programvara.

Lösung

iDRAC kan återställas med hjälp av systemidentifieringsknappen, iDRAC-webbgränssnittet, iDRAC-servicemodulen eller RACADM. Klicka på de olika avsnitten nedan om du vill ha mer information.

Systemidentifieringsknapp

För system med iDRAC finns vanligtvis en liten knapp som är märkt "i" (bild 1 och bild 2) på framsidan och baksidan av systemet. Den här i-knappen är systemidentifieringsknappen. Om du vill återställa iDRAC utan att starta om operativsystemet trycker du på och håller in systemidentifieringsknappen i minst 16 sekunder. Sluta trycka på knappen när kylläktarna börjar snurra med full hastighet och den främre LCD-skärmen (om det finns en) är avstängd. Nu startas iDRAC om utan att ändra sparade inställningar. Det kan ta en minut eller längre tills styrenheten startas om.

iDRAC i-knappen på servern PowerEdge R640
Bild 1: iDRAC i-knappen på servern PowerEdge R640

iDRAC i-knappen på Servern PowerEdge T620
Bild 2: iDRAC i-knappen på Servern PowerEdge T620

iDRAC-webbgränssnitt

Återställningar utförs på olika sätt för iDRAC9-webbgränssnittet och iDRAC7- och iDRAC8-webbgränssnittet. Klicka på iDRAC om du vill ha mer information.

iDRAC9-webbgränssnitt

  1. Anslut till iDRAC-webbgränssnittet.
  2. Logga in på gränssnittet genom att ange användarnamn och lösenord.
  3. Klicka på fliken Maintenance (underhåll).
  4. Välj Diagnostics (diagnostik).
  5. Klicka på Reset iDRAC (återställ iDRAC ) för att återställa iDRAC eller på Reboot iDRAC (starta om iDRAC ) för att återställa iDRAC.
Obs! Återställningsknappen i din miljö kan variera beroende på iDRAC-versionen av den fasta programvaran.

Knappen Återställ iDRAC i iDRAC9
Bild 3: Knappen Återställ iDRAC i iDRAC9

Starta om iDRAC-knappen
Bild 4: Starta om iDRAC-knappen

  1. Alternativt kan du klicka på Reset iDRAC to Default Settings för att återställa iDRAC till standardinställningarna. När du har klickat på Reset iDRAC to Default Setting (återställ iDRAC till standardinställningar) visas reset iDRAC to factory default window (återställ iDRAC till fabriksinställningarna). Den här åtgärden återställer iDRAC till fabriksinställningarna. Välj något av följande alternativ:
    • Bevara användar- och nätverksinställningar.
    • Radera alla inställningar och återställ användarna till leveransvärdet (rot-/leveransvärde).
    • Radera alla inställningar och återställ användarnamn och lösenord.
    • Radera alla inställningar och ställ in på Anpassad standardkonfiguration (anpassad konfigurationsfil måste laddas upp).
  2. Ett varningsmeddelande visas. Klicka på OK för att fortsätta.
Obs! Det går även att mata in iDRAC-kommandorader direkt från den här skärmen.

Webbgränssnitt för iDRAC7 och iDRAC8

  1. Anslut till iDRAC-webbgränssnittet.
  2. Logga in på gränssnittet genom att ange användarnamn och lösenord.
  3. Nere till höger på översiktsskärmen ser du Quick Launch Tasks.
  4. Klicka på Reset iDRAC (återställ iDRAC).
  5. Bekräfta åtgärden.

Återställ iDRAC-alternativet för iDRAC7 och iDRAC8
Bild 5: Återställ iDRAC-alternativet för iDRAC7 och iDRAC8

Så här återställer du iDRAC (Integrated Dell Remote Access Controller)

Längd: 00:01:24 (tt:mm:ss)
När det är tillgängligt kan du välja inställningar för undertext (undertext) med hjälp av CC-ikonen i den här videospelaren.

iDRAC-servicemodul

iDRAC Service Module (iSM) är en lätt programvara som kan installeras på PowerEdge-servrar som kör iDRAC7, iDRAC8 och iDRAC9. Med iSM 2.3 (och senare) kan administratören återställa iDRAC på distans när iDRAC inte svarar. Återställning av iDRAC med iDRAC-servicemodulen utförs på olika sätt oavsett om du använder Windows- eller Linux- eller VMware ESXi-operativsystem. Klicka på ett operativsystem om du vill ha mer information.

Windows

iDRAC Service Module tillhandahåller WMI-metoden, PowerShell-metoden och den genvägsmetod i programmenyn som iDRAC kan återställas från iDRAC från ett Windows-operativsystem. Klicka på metoderna nedan om du vill ha mer information om dem.

WMI-metod

Detta kan aktiveras antingen lokalt eller på distans med hjälp av WMI-kommandon (Windows Management Instrumentation).

Så här återställer du iDRAC med WMI-kommandon:

  1. Installera iDRAC-servicemodulen på värdoperativsystemet.
  2. Öppna Kommandotolken med administratörsbehörighet.
  3. Kör antingen det lokala WinRM-kommandot eller det fjärranslutna WinRM-kommandot.
    • Lokalt WinRM-kommando: winrm i iDRACHardReset wmi/root/cimv2/dcim/DCIM_iSMService?InstanceID="iSMExportedFunctions"
    • Kör WinRM-fjärrkommandot: winrm i iDRACHardReset wmi/root/cimv2/dcim/dcim_ismservice -u:"admin-username" -p:"password" -r:http://"remote-hostname or IP"/wsman -a:Basic -encoding:utf-8 -skipCACheck -skipCNCheck
Obs! Konfigurationen av WinRM-servern eller lyssnaren är obligatorisk för att använda fjärrkommandot WinRM. För konfiguration av WinRM som lyssnare; se Installation och konfiguration för Windows Fjärrhantering.
Använda PowerShell

Det här kan aktiveras antingen lokalt eller på distans med PowerShell-kommandon.

Så här återställer du iDRAC med hjälp av lokala PowerShell-kommandon:

Förutsättningar

  • Microsoft .NET Framework 64-bitars version 2.x eller senare krävs.
  • Policyn för att köra PowerShell-skript ska vara inställd på något av följande:
    • Set-ExecutionPolicy AllSigned
    • Set-ExecutionPolicy Unrestricted

iDRAC Service Module tillhandahåller även PowerShell cmdlet för lokal återställning av iDRAC. Så här använder du PowerShell för att återställa iDRAC:

  1. Öppna en Windows PowerShell-session som administratör.
  2. Skriv Invoke-iDRACHardReset och tryck sedan på Retur.
Obs! Alternativet -force kan användas för att återställa iDRAC via ett skript eller utan bekräftelsemeddelandet.

Så här använder Invoke-iDRACHardReset du kommandot från en fjärrsession med PowerShell:

Obs! Förutsättningen för fjärrmotsättning av PS är att WinRM konfigureras som lyssnare.
  1. Starta en PowerShell-session på hanteringsstationen.
  2. Aktivera fjärrstyrd PowerShell med cmdlet Enable PS-Remoting .
Genvägsmetod för programmenyn

Detta kan köras genom att logga in på operativsystemet med en fjärrskrivbordssession. Välj sedan iDRAC-återställningsalternativet på programmenyn.

Linux

På alla Linux-operativsystem som stöds av iSM tillhandahåller iSM kommandon som kan köras genom att logga in på operativsystemet med SSH eller motsvarande.

Kommandona är antingen:

  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset
  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset -f
Obs! Det finns ett alternativ för att ange force (-f) tillsammans med kommandot. Återställningen av iDRAC genomförs då utan att användare behöver bekräfta det.

VMware ESXi operativsystem

På alla ESXi-operativsystem som stöds i iDRAC Service Module; iSM 2.3 och senare har stöd för en leverantör av CMPI-metod. Detta gör det möjligt att utföra iDRAC-återställningen på distans med WinRM-fjärrkommandon. Till skillnad från Operativsystemen Windows (utom WMI) och Linux; ESXi ber inte användaren om en bekräftelse innan iDRAC återställs.

Kommandot är:

  • winrm i iDRACHardReset http://schemas.dell.com/wbem/wscim/1/cim-schema/2/root/cimv2/dcim/DCIM_iSMService?__cimnamespace=root/cimv2/dcim+InstanceID=iSMExportedFunctions -u:"root-username" -p:"password" -r:https://"Host-IP":443/wsman -a:basic -encoding:utf-8 -skipCNCheck -skipCACheck -skipRevocationcheck

Resultatet av åtgärden visas som ett heltalsvärde som tyder på att åtgärden har lyckats eller misslyckats.

Begränsningar:

På ESXi-versionerna ESXi 6.0 U1 och ESXi 6.0 U2 kan IPMI-drivrutinen sluta svara när iDRAC har återställts. Efter en hård återställning på vissa VMware ESXi-operativsystem kan IPMI-drivrutinen (ipmi_si_drv) sluta svara på grund av ett befintligt problem i IPMI-drivrutinen. Om IPMI-drivrutinen slutar svara läser du in IPMI-drivrutinen (ipmi_si_drv).

Så här läser du in:ipmi_si_drv

  1. /etc/init.d/sfcbd-watchdog stop
    esxcfg-module -u ipmi_si_drv => unload ipmi_si_drv
    esxcfg-module ipmi_si_drv => load ipmi_si_drv
    /etc/init.d/sfcbd-watchdog start
Obs! Alternativt kan administratören även starta om värdoperativsystemet för att lösa problemet.

RACADM

Verktyget Dell Remote Access Controller Admin (RACADM) är ett kommandoradverktyg som gör det möjligt att hantera på distans eller lokalt med iDRAC. RACADM-kommandon kan köras på distans från en hanteringsstation eller lokalt på systemet.

I alla fall startas endast iDRAC om och servern startas inte om. En omstart av iDRAC påverkar inte det operativsystem som körs. Det finns skillnader i kommandona mellan iDRAC9 och iDRAC7 eller iDRAC8. Klicka på iDRAC om du vill ha mer information.

iDRAC9

Återställning – Detta startar om iDRAC utan att ändra några iDRAC-konfigurationsinställningar.
Exempel: racadm racreset

Reset (framtvingad) – Om du lägger -f till några iDRAC-kommandon tvingar du fram kommandot.
Exempel: racadm racreset -f

Återställ iDRAC till fabriksinställningarna – detta återställer alla ändringar till fabriksinställningarna, men behåll användar- och nätverksinställningarna.
Exempel: racadm racresetcfg

Återställ iDRAC-konfigurationen till standard och återställ användaren till leveransvärdet.
Exempel: racadm racresetcfg -all

Återställ iDRAC-konfigurationen till standardinställningarna och återställ användaren till ett användarnamn root och lösenord calvinför.
Exempel: racadm racresetcfg -rc

Återställ iDRAC-konfigurationen till anpassade standardinställningar.
Exempel: racadm racrsetcfg -custom

Alla återställningskommandon för iDRAC9 finns i användarhandboken för iDRAC9 (Integrated Dell Remote Access Controller 9) version 3.00.00.00 | Dell USA (sidan 249).

iDRAC7 eller iDRAC8

Återställning – Detta startar om iDRAC utan att ändra några iDRAC-konfigurationsinställningar.
Exempel: racadm racreset

Om du lägger -f till några iDRAC-kommandon tvingar du fram kommandot.
Exempel: racadm racreset -f

Återställ iDRAC till fabriksinställningarna – detta återställer alla ändringar till fabriksinställningarna. Detta tar bort användar- och nätverksinställningarna.
Exempel: racadm racresetcfg

Alla återställningskommandon för iDRAC7 eller iDRAC8 finns i kommandoradsgränssnittsmanualen för iDRAC 8/7 v2.81.81.81 RACADM (sida 105).

Betroffene Produkte

iDRAC7, iDRAC8, iDRAC9, PowerEdge XR2, PowerEdge C4130, Poweredge C4140, PowerEdge c6320, PowerEdge c6320p, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, Poweredge FC430, Poweredge FC630, PowerEdge FC640 , Poweredge FC830, PowerEdge FD332, PowerEdge FM120x4 (for PE FX2/FX2s), PowerEdge FX2/FX2s, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M420, PowerEdge M520, PowerEdge M520 (for PE VRTX), PowerEdge M620, PowerEdge M620 (for PE VRTX), PowerEdge M630, PowerEdge M630 (for PE VRTX), PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M820, PowerEdge M820 (for PE VRTX), PowerEdge M830, PowerEdge M830 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R220, PowerEdge R230, PowerEdge R240, PowerEdge R250, PowerEdge R320, PowerEdge R330, PowerEdge R340, PowerEdge R350, PowerEdge R420, PowerEdge R420XR, PowerEdge R430, PowerEdge R440, PowerEdge R450, PowerEdge R520, PowerEdge R530, PowerEdge R530xd, PowerEdge R540, PowerEdge R550, PowerEdge R620, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R720, PowerEdge R720XD, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R820, PowerEdge R830, PowerEdge R840, PowerEdge R860, PowerEdge R920, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T130, PowerEdge T140, PowerEdge T150, PowerEdge T320, PowerEdge T330, PowerEdge T340, PowerEdge T350, PowerEdge T420, PowerEdge T430, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T620, PowerEdge T630, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t ...

Produkte

iDRAC Service Module
Artikeleigenschaften
Artikelnummer: 000126703
Artikeltyp: Solution
Zuletzt geändert: 21 Sep. 2023
Version:  17
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.