Getting error when trying to connect nsrjb on the remote storage node
Summary: Getting the below error when trying to connect nsrjb on the remote storage node. nsrjb: User xxx on "Remote_Storagenode_hostname" does not have "Operate Devices and Jukeboxes" privilege on "Networker_Server_hostname" Reset and inventory also gives the same error. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When running the nsrjb command on a remote NetWorker storage node, the following error message appears:
C:\> nsrjb ####:nsrjb: Failed to connect to the NSR service on NWserver_HostName: Program not registered If on a storage node, enter the NSR server hostname? [NWserver_HostName]: using NWserver_Hostname as the NSR server ####:nsrjb: User 'UserName' on 'StorageNode_Hostname' does not have 'Operate Devices and Jukeboxes' privileges on 'NWserver_HostName'.
Cause
The user account that issued nsrjb on the Remote Storage node does not have the privilege to perform device and autochanger operations.
Resolution
From an elevated prompt on the NetWorker server, run the below command to add the privileges to the user on the Storage Node host.
nsraddadmin UserName@StorageNode_Hostname
NOTE: Replace
UserName and StorageNode_Hostname with the corresponding values from the nsrjb error.
Alternatively, follow the below steps from NetWorker Management Console (NMC) to add the privileges to the user on the host.
1. In the NMC, click the Server tab.
2. On the Server window, select User Groups.
3. Right-click Application Administrators and select Properties.
4. In the User Group Properties Application Administrators window, under Users, add:
user=UserName,host=StorageNode_Hostname
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000293578
Article Type: Solution
Last Modified: 16 Apr 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.