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Intune Fails to Deploy Dell Optimizer Version 4.2.2 When Downloaded from the Microsoft Store

Summary: Information about Intune not deploying Dell Optimizer version 4.2.2 if it is downloaded from the Microsoft Store.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

App Does Not Have a Valid Latest Package Version Error

Intune shows an error message, "The selected app does not have a valid latest package version" (Figure 1).
InTune Error Message
Figure 1

Note: Available exclusively on select Dell Latitude, Precision, OptiPlex, and Rugged PCs.

Cause

Dell Optimizer did not pass the Intune verification that requires apps to install on all hardware (Dell and non-Dell).

Resolution

Manually Deploy Dell Optimizer

As a workaround, IT Admin can try the following to manually deploy Dell Optimizer through Intune.

  1. Download the Dell Optimizer installer from Dell.com
  2. Follow the below instructions:
  3. Install the software using this command: Install command: Dell-Optimizer-Application_xxxxx_WIN_x.x.x.x_A00.EXE /passthrough /silent /InstallDotNet=true /FACTORY=TRUE
 
Note: To uninstall, use the following command: Uninstall command: Dell-Optimizer-Application_xxxxx_WIN_x.x.x.x_A00.EXE /passthrough /silent /remove


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Affected Products

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations
Article Properties
Article Number: 000224821
Article Type: Solution
Last Modified: 13 Mar 2025
Version:  5
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