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PowerStore - NVMe Expansion drive may appear offline or missing following drive replacement

Summary: Replacing a drive in an NVMe enclosure requires waiting 10 minutes before adding the replacement drive.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

If the new drive is replaced within 10 minutes of a faulty drive removal, the new drive may not be properly updated in PowerStoreOS.
The PowerStore Manager UI may show an empty slot, or a failed slot as shown in the below example:
PowerStore Manager UI may show an empty slot, or a failed slot

In addition, the alert 0X00307104 "Drive in bus <x> enclosure <n> slot <m> has been removed" may also appear:

alert 0X00307104

 

Cause

When replacing a drive in an NVMe enclosure, the NVMe control resources for the old drive are not immediately freed. Inserting a new drive before the old resources are free may cause the new drive to be missing or failed.

Resolution

This issue is resolved in PowerStoreOS 3.6. 

Workaround

  1. Replacing a drive in an NVMe enclosure requires, until further update, waiting for 10 minutes between removing the faulty drive and adding the new drive.
  2. If a drive was replaced without waiting and the issue of the article occurs, try removing the failed/missing drive and then  wait for 10 m before inserting the drive back.
  3. If the issue persists, replace the faulty drive.
  4. If the issue still persists, Contact Dell Technologies technical support or your service provider for assistance.

Affected Products

PowerStore
Article Properties
Article Number: 000208451
Article Type: Solution
Last Modified: 14 May 2024
Version:  3
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