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Integrated Data Protection Appliance RUCK: vCenter Checks Fail Due to Applmgmt Service being Stopped

Summary: Rapid Upgrade Checker (RUCK) fails on validate_vc_password_expiry, validate_vc_gateway, and vc_hostname_check or validate_vsan.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

RUCK fails on DP4400 when checking:

validate_vc_password_expiry

validate_vc_gateway

vc_hostname_check

On larger models, RUCK fails when checking:

validate_vsan
 
Screenshot of Failed Upgrade Rediness Status
Screenshot of additional Failed Upgrade Rediness Status

Cause

This is due to applmgmt not running on the vCenter.

root@dpappliance-vcsa [ ~ ]# service-control --status --all
Stopped:
 applmgmt vmcam vmware-imagebuilder vmware-mbcs vmware-netdumper vmware-rbd-watchdog vmware-updatemgr vmware-vcha vsan-dps
Running:
 lwsmd pschealth vmafdd vmcad vmdird vmdnsd vmonapi vmware-analytics vmware-certificatemanagement vmware-cis-license vmware-cm vmware-content-library vmware-eam vmware-perfcharts vmware-pod vmware-postgres-archiver vmware-rhttpproxy vmware-sca vmware-sps vmware-statsmonitor vmware-sts-idmd vmware-stsd vmware-topologysvc vmware-vapi-endpoint vmware-vmon vmware-vpostgres vmware-vpxd vmware-vpxd-svcs vmware-vsan-health vmware-vsm vsphere-client vsphere-ui

This service may be down on its own, or multiple services may be down due to expired vCenter certificates. 

Resolution

  1. Log in to vCenter as root
  2. Run shell (if you get the Command > prompt)
  3. Run the following command to confirm applmgmt is stopped
service-control --status --all
  1. Run the following command to start applmgmt:
service-control --start applmgmt
  1. Run the following command to confirm applmgmt is now running:
service-control --status --all
 
Screenshot of commands being run
  1. Run the RUCK tool again and confirm precheck passed for the mentioned failures:
Screenshot of Successful Upgrade Rediness Status

Additional Information

This article applies only if applmgmt service is not running, the above failed checks may be due to some other issues.

Affected Products

PowerProtect DP4400, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000206249
Article Type: Solution
Last Modified: 17 Apr 2024
Version:  8
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