Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

OptiPlex 7090 and 3090 Computers With Ubuntu 20.04 May Not Display Video When Turning on or Hot Plugging a Monitor to WD19 or WD19S Docking Station

Summary: This article provides information about how to troubleshoot video issues with OptiPlex 7090 and 3090 computers running on Ubuntu 20.04. The issue occurs when turning on or hot plugging a monitor to a WD19 or WD19S series docking station. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

OptiPlex 7090 and 3090 computers with Ubuntu 20.0.4 that is connected to Dell WD19 or WD19S series docks such as WD19, WD19TB, WD19DC, WD19S, WD19TBS, and WD19DCS may see intermittent video or display issues.

This issue is seen when the user does the following steps after turning on the computer and boots into Ubuntu operation system:

  1. When the monitor is hot plugged into the video port on the docking station.
  2. When the monitor is hot plugged into the video port on the computer.

Cause

This issue happens because the Linux Window Management application “GNOME Mutter” does not handle hot-plugin docking events. The Intel i915 chipset digital rights management (DRM) also did not implement Link-Training Tunable PHY Repeater (LTTPR) features in Linux kernel 5.6.

Resolution

To resolve the video or display issue, follow the steps that are mentioned below.

  1. From the desktop screen, open Terminal. You can also use CTRL + ALT + T keyboard shortcut to open the terminal.
  2. In the terminal, type sudo apt-get install linux-oem-20.04b and press Enter.
  3. You will be prompted for the administrator password. Type the administrator password and press Enter.
  4. Restart the computer.

If the above steps did not resolve the issue, reinstall the Ubuntu operating system. To learn more about reinstalling Ubuntu on your Dell computer, go to https://www.dell.com/support/home/drivers/osiso/recoverytool/ubt20.

After reinstalling the Ubuntu operating system, if issue persists when you hot plug the display cable, follow the troubleshooting steps available in the user guide of the docking station. To access the user guide, go to https://www.dell.com/support/manuals and identify your Dell docking station using the Service Tag of the docking station. Or, click Browse all products and select the docking station from the catalog.

Affected Products

Dell Dock WD19, Dell Performance Dock - WD19DC, Dell Performance Dock – WD19DCS, Dell Dock – WD19S, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS, OptiPlex 3090 Ultra, OptiPlex 7090 Ultra
Article Properties
Article Number: 000182438
Article Type: Solution
Last Modified: 22 Sept 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.