PowerStore: An Import Session Results in "Request timed out" when Canceling.

Summary: Resolving 'Request Timed Out' errors when canceling Import Sessions.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After canceling one of the Import sessions, the PowerStore Manager may time out with:

Request timed out

Cause

An operation may take more time than the UI allows, and could result in a timeout. Operations on the host side could also contribute to this long-running operation and timeout.

This issue has been observed in environments where an import of sixteen Unity volumes is in the Ready to Cutover state. A Red Hat 7.4 host with the PowerStore Plugin is used as the host. After canceling one of the import sessions, PowerStore gives a "Request timed out" message.

The environment where this was observed: 

  • Linux Red Hat 7.4 Host
  • A Unity array
  • Multiple Import Sessions at the Ready to Cutover state

Resolution

  1. Refresh the Host on the PowerStore, follow PowerStore Manager > Migration > Import External Storage > Source Array > IMPORT STORAGE > MORE ACTIONS > Refresh Hosts.
  2. On the Linux Host, verify the status of the volume where the timeout occurred, using the Import CLI utility:
# importcli status
Generating diagnostic data, please wait...
========================================================
Volume list
========================================================
  Target WWID: 6006016023003e00fcfe745ecf2858ce
    Array Type: UNITY
    Dev mapper name: mpathq
    DM dev name: /dev/dm-7
    SD devices list:
     /dev/sdp
     /dev/sdq
    Volume Size: 20.00 GB
    Import Status: READY FOR IMPORT

 

  1. If the status shows READY FOR IMPORT, retry the Import operation.
  2. If the status shows as IMPORT IN PROGRESS, the cancellation job failed on the Host. Retry the Canceled operation again from PowerStore. 
  3. If the issue persists, contact Dell Technical Support and mention this article number.

Affected Products

PowerStore
Article Properties
Article Number: 000139921
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  5
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