Start a Conversation

Unsolved

A

1 Rookie

 • 

1 Message

15

August 19th, 2024 21:47

When setup VLANs the SIP devices randomly gets disconnected

Appreciate your help before hand for your support. So I recently started creating VLANs for a network where I have the following setup: 

Problem: Since I started segmenting the network I have issues with the SIP phone devices. They randomly get disconnected from the SIP server, and sometimes gets totally disconnected. 

As a core switch I have the following config:


SW-Core#show running-config
!Current Configuration:
!System Description "PowerConnect 6224F, 3.3.1.10, VxWorks 6.5"
!System Software Version 3.3.1.10
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20
exit
ip telnet port 22
hostname "SW-Core"
sntp unicast client enable
sntp server 10.10.1.1
clock timezone -5 minutes 0
stack
member 1 3
member 2 3
exit
ip address 10.10.1.199 255.255.255.0
ip default-gateway 10.10.1.1
ip address vlan 10


interface vlan 10
name "DLX-VLAN"
exit
interface vlan 20
name "Urba"
exit
username "admin" password 173b80702cfae20cf7021168d016f12b level 15 encrypted
ip ssh server
ip ssh port 23
!
interface ethernet 1/g1
description 'sw-hp-OficinasUrba'
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g14
description 'Urba'
exit
!
interface ethernet 1/g21


switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g22
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g23
switchport access vlan 10
exit
!
interface ethernet 1/g24
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/xg1
switchport access vlan 10
exit


!
interface ethernet 1/xg2
switchport access vlan 10
exit
!
interface ethernet 1/xg3
switchport access vlan 20
exit
!
interface ethernet 2/g1
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g2
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g3
switchport mode trunk


switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g4
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g5
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g6
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g7
switchport mode trunk
switchport trunk allowed vlan add 10,20


exit
!
interface ethernet 2/g8
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g9
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g10
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g11
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit


!
interface ethernet 2/g12
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g13
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g14
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g15
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!


interface ethernet 2/g16
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g17
description 'sw-acceso-JuanBautista-Kennedy'
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g18
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g19
description 'sw3-acceso-JuanBautista-Kennedy'
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit


!
interface ethernet 2/g20
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g21
description 'sw-acceso-Bolona'
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g22
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 2/g23
description 'sw-salida-Bolona'
switchport mode trunk
switchport trunk allowed vlan add 10,20


exit
!
interface ethernet 2/g24
description 'sw-Salida-PlazaDanin'
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
enable password 173b80702cfae20cf7021168d016f12b encrypted
exit

The other switches where the SIP phones are connected directly have the following config: 

SW-AccesoKennedy# show running-config
Building configuration...

Current configuration:
hostname SW-AccesoKennedy
vlan learning independent
!
vlan 1
!
vlan 10
!
vlan 20
!
interface gigabitethernet1
 ingress filtering enable
 switchport trunk allowed vlan add 10,20
 switchport trunk native vlan 10
!
interface gigabitethernet2
 ingress filtering enable
 switchport trunk allowed vlan add 10,20
 switchport trunk native vlan 10
!
interface gigabitethernet3
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface gigabitethernet4
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface gigabitethernet5
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface gigabitethernet6
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface gigabitethernet7
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface gigabitethernet8
 switchport trunk allowed vlan add 10,20
 switchport trunk native vlan 20
!
interface gigabitethernet9
 ingress filtering enable
 switchport access vlan add 20
 switchport trunk native vlan 20
!
interface lo
!
interface vlan1
 ip address 192.168.10.1/24
 shutdown
!
interface vlan10
 ip address 10.10.1.83/24
 no shutdown
!
ip route 0.0.0.0/0 10.10.1.1
!
clock timezone 12
clock set 0:0:0 1 1 2009
snmp-server community public ro
snmp-server community private rw
dot1x radius server-ip 192.168.10.100 key radius-key 1812 1813
ntp peer enable
ntp peer primary 10.10.1.1
!

I appreciate any feedback that may help. 

Moderator

 • 

3.4K Posts

August 20th, 2024 04:47

Hi,

 

There might be an issue with firmware 3.3.1, it would be advisable to update it to the latest, 3.3.18.1.

 

https://dell.to/3MbUTu5

No Events found!

Top