Unsolved
1 Rookie
•
2 Posts
0
486
switch embedded teaming
We have two Dell N4032 (Powerswitch N4000 series). We would to use SET (switch embedded teaming) and have put that on Dell servers. we use tagged traffic also. Normally we would do this at the two switche. But it doesen't work:
channel-group 1 mode active
description "HOST-1"
switchport mode general
interface port-channel 1
description "HOST-1"
switchport mode general
switchport general allowed vlan add 100,102,105 tagged
At the server we does this:
#1
New-VMSwitch -Name SETSwitch -NetAdapterName "NIC1","NIC2" -EnableEmbeddedTeaming $true -MinimumBandwidthMode Weight
#2
Set-VMSwitchTeam -Name SETSwitch -LoadBalancingAlgorithm Dynamic -NetAdapterName "NIC1","NIC2"
#3
Rename-VMNetworkAdapter -ManagementOS -Name "SetSwitch" -NewName "VEthernet (Mgmt)"
#4
Set-VMNetworkAdapterVlan -VMNetworkAdapterName "VEthernet (Mgmt)" -Access -VlanId 100 -ManagementOS
Bu we can't get connection between HOST and the two switche. Any idea what we do wrong. I'm pretty shure that it's the two switche that we do wrong config.
The_LostIT_Guy
1 Rookie
1 Rookie
•
66 Posts
0
February 23rd, 2024 18:57
@fkil08924c SET supports only switch-independent configuration by using either Dynamic or Hyper-V Port load-balancing algorithms. Destroy the port-channel and just leave as two independent links. Windows will handle the load balancing and failover with the Switch Embedded Team.
(edited)
The_LostIT_Guy
1 Rookie
1 Rookie
•
66 Posts
0
February 27th, 2024 18:04
@fkil08924c Another thing you may want to consider is Uplink Failure Detection) UFD.
OS9 Reference | OS10 Reference
fkil08924c
1 Rookie
1 Rookie
•
2 Posts
0
February 29th, 2024 09:43
Hi Guys
Still not solved
We have now tryed against two Dell S4048-ON switche. They are in a VLT domain. Still switch embedded teaming and same config at the host. The host have two Broadcom NetXtreme E-Series Advanced Dual-port 10Gb SFP+ Ethernet OCP 3.0 Adaptere. We try two things. Whit and whitout portchannel on the two switche. In both scenaria we get slow networksspeed (the upload is worst). But if we disable one of the netcard at the HOST then network seems to be fine. And that is in booth scenaria. So it looks like some load balancing is failing. But we can't solve what's wrong. We also tryed whit and whitout MTU size at both scenarias.
Here is switch config from both scenarias (same at both switche):
1:
interface TenGigabitEthernet 1/1
description HOST-1 intNIC1
no ip address
switchport
no shutdown
interface Vlan 100
no ip address
tagged TenGigabitEthernet 1/1
no shutdown
2:
interface TenGigabitEthernet 1/1
description HOST-1 intNIC1
no ip address
mtu 9216
no shutdown
interface Port-channel 1
description "HOST-1"
no ip address
switchport
channel-member TenGigabitEthernet 1/1
no shutdown
interface Vlan 100
description management
no ip address
tagged Port-channel 1
no shutdown
(edited)
The_LostIT_Guy
1 Rookie
1 Rookie
•
66 Posts
0
July 31st, 2024 16:04
@fkil08924c I know that my reply is very late and that you likely solved the problem by now, but according to the config that your provided, Interface TenGigabitEthernet 1/1 is still a member of port-channel 1. Removing the interface from the port-channel and then removing the port-channel is the correct thing to do.
Did you end up doing this?
(edited)
DELL-Young E
Moderator
Moderator
•
4.2K Posts
0
August 8th, 2024 01:31
Hello, this is for those who couldn't get answers.
please refer to the guides below to know more about VLT domain and VLT port-channels.
https://dell.to/3YHf1vP
https://dell.to/4cnRG5k
https://dell.to/3YxCVd3
https://dell.to/3WV7k3G
https://dell.to/3WSd0LI
https://dell.to/3WT9y3C
This example code creates VLANs 22, 24, and 26. VLAN 22 is untagged traffic on interface gi 0/2, but tagged on ports gi 0/3-4. VLANs 24 and 26 are also tagged on those same 2 ports.
Force10#config
Force10(conf)#interface vlan 22
Force10(conf-if-vlan)#untagged gi 0/2
Force10(conf-if-vlan)#tagged gi 0/3-4
Force10(conf)#interface vlan 24
Force10(conf-if-vlan)#tagged gi 0/3-4
Force10(conf)#interface vlan 26
Force10(conf-if-vlan)#tagged gi 0/3
Force10(conf-if-vlan)#exit
Please note that you did not configure VLT port-channels accordingly in VLT domain infrastructure and LACP port-channel recommended in VLT domain also. Learning more about it through the guides above could help you.
Respectfully,