Unsolved
1 Rookie
•
4 Posts
0
41
Dell OS10 modle Z9100-ON 32x100GbE
traffic within vrf not passing from one port ethernet1/1/1:1 to ethernet1/1/1:2.
config
configure terminal
ip vrf RED
exit
ip vrf BLUE
exit
interface ethernet1/1/1:1
ip vrf forwarding RED
ip address 192.168.10.1/24
no shutdown
exit
interface ethernet1/1/1:2
ip vrf forwarding RED
ip address 192.168.20.1/24
no shutdown
exit
interface ethernet1/1/1:3
ip vrf forwarding BLUE
ip address 192.168.10.1/24
no shutdown
exit
interface ethernet1/1/1:4
ip vrf forwarding BLUE
ip address 192.168.20.1/24
no shutdown
exit
ip route vrf RED 1.1.1.0/24 interface DUTINT02
ip route vrf BLUE 1.1.1.0/24 interface DUTINT04
end
DELL-Chris H
Moderator
Moderator
•
8.9K Posts
0
May 29th, 2024 15:11
prvzkhn
1 Rookie
1 Rookie
•
4 Posts
0
May 29th, 2024 16:53
@DELL-Chris H
**dell04:Running command 'interface ethernet1/1/1:2'
**dell04:Running command 'no shutdown'
**dell04:Running command 'ip vrf forwarding RED'
**dell04:Running command 'interface ethernet1/1/1:3'
**dell04:Running command 'ip vrf forwarding BLUE'
**dell04:Running command 'ip address 192.168.10.1/24'
these two port are in two different vrf, communication between them should not be happening as per our design.
Its simple one switch topology, interface ethernet1/1/1:1 and ethernet1/1/1:2 are in same vrf, any packed received with destination ip in subnet of 192.168.20.0/24' should exit ethernet1/1/1:2 but its not happening. If I take out VRF it works.
I went through document, are you suggesting to run OSPF routing protocol to use BFD? its one device topology . relying on connected subnets and two static routes
prvzkhn
1 Rookie
1 Rookie
•
4 Posts
0
May 30th, 2024 05:58
dell04# ping vrf RED 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
64 bytes from 192.168.10.1: icmp_seq=1 ttl=64 time=0.100 ms
64 bytes from 192.168.10.1: icmp_seq=2 ttl=64 time=0.047 ms
^C
--- 192.168.10.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1021ms
rtt min/avg/max/mdev = 0.047/0.073/0.100/0.027 ms
dell04# ping vrf RED 192.168.20.1
PING 192.168.20.1 (192.168.20.1) 56(84) bytes of data.
64 bytes from 192.168.20.1: icmp_seq=1 ttl=64 time=0.072 ms
64 bytes from 192.168.20.1: icmp_seq=2 ttl=64 time=0.059 ms
64 bytes from 192.168.20.1: icmp_seq=3 ttl=64 time=0.058 ms
^C
--- 192.168.20.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2033ms
rtt min/avg/max/mdev = 0.058/0.063/0.072/0.006 ms
dell04# ping vrf RED 192.168.10.1 192.168.20.1
PING 192.168.20.1 (192.168.20.1) 56(124) bytes of data.
^C
--- 192.168.20.1 ping statistics ---
20 packets transmitted, 0 received, 100% packet loss, time 19453ms
dell04#