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SourceOne: Archiving or indexing data stopped due to low free space

Summary: SourceOne: Email Management: Archiving or indexing, or both of data has stopped due to low free space on Message_Center, Index locations or .emx file storage locations.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Message_Center, Index or emx file storage locations, or both, are out of space which causes processing for one or more SourceOne functions to stop.
By default, SourceOne warns about free space on Message_Center and Index locations when available free space drops below 20%.
When free space drops below 5% on either of those locations, processing stop.
For example if the Message_Center and Indexes are stored on different locations and the Message_Center location's available free space drops below 5%, worker machines cannot archive data as the archive servers log this message in the EMC event log:

Insufficient free space on <Message_Center location>.  Free%: <Percent Free> , Required%: <Required Percent>%

Also, archive servers log this error message in the ExAsArchive.exe.log:

Unable to write to the repository storage

If the ".emx" storage location is out of space, one of these messages is logged in the ExAsArchive.exe.log on archive servers:

Failed to Create New Volume in <emx File Location> (Error Code) FLAGS(VolumeFlags)

Or

Unable to write file

Indexing servers log this warning when processing stops due to lack of free space:

Skipping Index Location '<Path to index location>' has insufficient freespace, Current: <Current Free Space> percent, Min: <Required Free Space> percent

 

Cause

There is not enough free space to complete the operation.

 

Resolution

Add space to locations that are lacking free space:

  1. If the index locations are out of space and space cannot be added to the existing locations, Add new locations to the archive folders.
    The old locations are not used for indexing of new data going forward.
    If there are files in the index DropDir locations for the Index shares that are out of space, engage Dell Technologies Technical Support to move the affected indexes to the new locations.

  2. If one or more Message_Center locations are lacking free space, engage Dell Technologies technical support to determine why the Message_Center location is running low on space.

  3. If the storage location for ".emx files" created by SourceOne are out of space, add more space to the device or create a new archive folder and mapped folder that use a new storage location and change the existing activities to archive data into the new mapped folder.

See the following 'SourceOne Email Management Administration Guide' sections for details on folder configuration when creating new archive folders or modifying existing folders:

  • Configuring Native Archive folders and storage
  • Configuring Mapped Folders
  • Modifying indexing properties of archive folders

 

Additional Information

  • When Indexing transactions are piling up in the index DropDir, the Message_Center\Unpack_Area is also affected because the Unpack_Area is storing raw data to be indexed that will be deleted after the transactions in the index DropDir locations are processed.
  • Ensure that all servers that have the Index role enabled are configured to index all archive servers and that the archive folders are configured to allow at least one indexing server to index data for each folder.
  • Under one or more Native Archive nodes in the SourceOne console, check each server's Properties.
  • Look on the Indexing tab.
  • If Indexing is 'Enabled,' then select the other archive servers that the current archive server is allowed to index data for.
  • Typically, all indexing servers are set to index all other archive servers, but that is not required so if the indexing permission is limited, one must be sure that all archiving servers have at least one indexing server that is allowed to index it's data, otherwise, transactions accumulate in DropDir, causing Message_Center space to decrease.
  • Also, check the Properties of Archive Folders by looking at the Indexing tab.
  • Double-click each Storage Path to verify that at least one indexing server is assigned to each storage location, otherwise index transactions accumulate in DropDir folders, also causing Message_Center space to decrease.

 

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Discovery Manager, SourceOne Email Management
Article Properties
Article Number: 000050283
Article Type: Solution
Last Modified: 31 Mar 2025
Version:  4
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